Андрей Смирнов
Время чтения: ~5 мин.
Просмотров: 1

Как сделать таблицу в фотошопе

Макет

Все вышеперечисленное предоставляет широкий функционал для настройки внешнего вида. А что касается конкретно содержания, то здесь нужно переходить в соседнюю вкладку – «Макет».

  1. Первые три области можно условно соединить вместе, так как они в целом предназначены для расширения размеров компонента, создания новых строк, столбцов и так далее. Здесь же можно работать с ячейками и таблицами в целом.

Следующий раздел – «Размер ячейки» — позволяет форматировать габариты каждой отдельной ячейки, создавая дополнительные элементы нужных размеров.

«Выравнивание» и «Размер таблицы» предлагает возможности по оптимизации – например, здесь можно сравнять все выступающие за внешние границы ячейки, выровнять края, задать некоторые параметры для текста внутри, и так далее. «Упорядочение» также дает возможности перестановки определенных элементов таблицы относительно других компонентов слайда. Например, так можно переместить этот компонент на передний край.

Как итог, используя все эти функции, пользователь способен создать таблицу абсолютно любой степени сложности для самых разных целей.

Создание автопроверки

Но, Excel позволяет сделать не просто кроссворд, но и кроссворд с проверкой, в котором сразу автоматически будет отражаться правильно пользователь разгадал слово или нет.

Для этого, в этой же книге на новом листе делаем таблицу. Первый её столбец будет называться «Ответы», и мы туда впишем ответы на кроссворд. Второй столбец будет назваться «Введено». Тут отображаются данные, введенные пользователем, которые будут подтянуты из самого кроссворда. Третий столбец будет называться «Совпадения». В нём, если ячейка первого столбца будет совпадать с соответствующей ячейкой второго столбца, отобразиться цифра «1», а иначе – «0». В этом же столбце внизу можно сделать ячейку для общей суммы отгаданных ответов.

Теперь, нам посредством формул предстоит связать таблицу на одном листе с таблицей на втором листе.

Было бы просто, если каждое слово кроссворда пользователь вводил в одну ячейку. Тогда бы мы просто связали ячейки в столбце «Введено» с соответствующими ячейками кроссворда. Но, как мы знаем, в каждую ячейку кроссворда вписывается не одно слово, а одна буква. Воспользуемся функцией «СЦЕПИТЬ», чтобы объединить эти буквы в одно слово.

Итак, кликаем по первой ячейке в столбце «Введено», и жмем на кнопку вызова Мастера функций.

В открывшемся окне Мастера функций, находим функцию «СЦЕПИТЬ», выделяем её, и кликаем по кнопке «OK».

Открывается окно аргументов функции. Кликаем на кнопку, расположенную справа от поля ввода данных.

Окно аргументов функции сворачивается, а мы переходим на лист с кроссвордом, и выбираем ячейку, где расположена первая буква того слова, которое соответствует строчке на втором листе документа. После того, как выбор сделан, опять жмем на кнопку слева от формы ввода, чтобы вернуться в окно аргументов функции.

Подобную операцию проделываем с каждой буквой слова. Когда все данные введены, жмем на кнопку «OK» в окне аргументов функции.

Но, пользователь при разгадывании кроссворда может использовать как строчные, так и прописные буквы, а программа будет расценивать их как разные символы. Для того, чтобы этого не случилось, становимся на нужную нам ячейку, и в строке функций прописываем значение «СТРОЧН». Остальное все содержимое ячейки берем в скобки, как на изображении ниже.

Теперь, какими бы буквами не писали пользователи в кроссворде, в столбце «Введено» они будут преобразовываться в строчные.

Подобную процедуру с функциями «СЦЕПИТЬ» и «СТРОЧН», нужно проделать с каждой ячейкой в столбце «Введено», и с соответствующим ей диапазоном ячеек в самом кроссворде.

Теперь, для того, чтобы сравнить результаты столбца «Ответы» и «Введено», нам в столбце «Совпадения», нужно использовать функцию «ЕСЛИ». Становимся на соответствующую ячейку столбца «Совпадения», и вводим функцию такого содержания «=ЕСЛИ(координаты столбца «Ответы»=координаты столбца «Введено»;1;0). Для нашего конкретного случая из примера, функция будет иметь вид «=ЕСЛИ(B3=A3;1;0)». Подобную операцию проделываем для всех ячеек столбца «Совпадения», кроме ячейки «Итого».

Затем выделяем все ячейки в столбце «Совпадения», включая ячейку «Итого», и кликаем по значку автосуммы на ленте.

Теперь на данном листе будет проводиться проверка правильности разгаданного кроссворда, а результаты правильных ответов будут отображаться в виде общего балла. В нашем случае, если кроссворд будет разгадан полностью, то в ячейке суммы должно появиться число 9, так как общее количество вопросов равно этому числу.

Чтобы результат разгадывания был виден не только на скрытом листе, но и тому человеку, который разгадывает кроссворд, можно опять воспользоваться функцией «ЕСЛИ». Переходим на лист, содержащий кроссворд. Выбираем ячейку, и вводим туда значение по такому шаблону: «=ЕСЛИ(Лист2!Координаты ячейки с общим баллом=9;«Кроссворд разгадан»;«Подумайте ещё»)». В нашем случае, формула имеет такой вид:«=ЕСЛИ(Лист2!C12=9;«Кроссворд разгадан»;«Подумайте ещё»)».

Таким образом, кроссворд в программе Microsoft Excel полностью готов. Как видим, в этом приложении можно не просто быстро сделать кроссворд, но и создать в нём автопроверку.

Опишите, что у вас не получилось.
Наши специалисты постараются ответить максимально быстро.

Конструктор таблиц

Базово скрытая вкладка шапки, которая появляется при выборе таблицы любого типа – хоть стандартного, хоть ручного.

Здесь можно выделить следующие важные области и элементы.

  1. «Параметры стилей таблиц» позволяют отмечать специфические разделы, например, строку итогов, заголовки, и так далее. Это же позволяет назначать специфическим отделам уникальный визуальный стиль.
  2. «Стили таблиц» имеют два раздела. Первый предлагает выбор из нескольких базовых заложенных дизайнов для этих элементов. Выбор здесь достаточно большой, редко когда приходится изобретать что-то новое.
  3. Вторая часть – область ручного форматирования, позволяющая самостоятельно настраивать дополнительные внешние эффекты, а также цветовую заливку ячейкам.
  4. «Стили WordArt» позволяют добавлять специальные надписи в формате изображений с уникальным дизайном и внешним видом. В профессиональных таблицах почти не используется.
  5. «Нарисовать границы» — отдельный редактор, позволяющий вручную добавлять новые ячейки, расширять границы и так далее.
Рейтинг автора
5
Материал подготовил
Максим Иванов
Наш эксперт
Написано статей
129
Ссылка на основную публикацию
Похожие публикации